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INTRODUCTION TO CATIA 

In cad laboratory we are going to study about how to create a model of engineering 

objects and also how to create an assembly of modeled objects. The modeling software’s like 

CATIA, Pro e, Unigraphics are generally used in mechanical engineering field for the 

modeling. In this lab catia-v5r18 software is used to do the exercises. 

 

CATIA (Computer Aided Three-dimensional Interactive Application) is a multi- 

platform CAD/CAM/CAE. It is written in the C++ programming language. Commonly referred 

to as a 3D Product Lifecycle Management software suite, CATIA supports multiple stages of 

product development (CAx), from conceptualization, design (CAD), manufacturing (CAM), 

and engineering (CAE).CATIA can be customized via application programming interfaces 

(API). V4 can be adapted in the Fortran and C Programming languages under an API called 

CAA (Component Application Architecture). V5 can be adapted via the Visual Basic and C++ 

programming languages, an API called CAA2 or CAA V5 that is a component object model 

(COM)-like interface. Although later versions of CATIA V4 implemented NURBS, V4 

principally used piecewise polynomial surfaces. 

 
AN OVERVIEW OF CATIA DESIGN SOFTWARE 

 

Optimal Sharing 

 

Catia V6 users will get access to a unique, collaborative 3 dimensional environments that can 

be access by an unlimited number of people online. This allows people from across the globe 

to collaborate in a virtual environment. It has been designed to not only allow for online 

cooperation, but also makes offline sharing and designing easy to integrate as well. 

 

Simplified Product Development 

 

Creating a new product can be a long and complex process. It encompasses multiple design 

phases including the initial design, overall development, and manufacturing. Catia V6 

decreases the complexity and length of the entire project because it integrates various stages of 

the development process so that they can be controlled and modified on a single platform. It 

does this by using an approach to systems engineering known as RFLP. This allows you to 

create several versions of the same product using different sets of requirements. This gives you 

a comprehensive look at what the final product could be Seamless Transitioning. 

 

Every version of the CATIA design software is designed to allow for seamless integration with 

previous versions. This makes upgrading a simple process and can be completed without losing 

any of the information that has already been stored. CATIA design software has found its way 

into more and more industries with each passing year. Traditionally, it gained notoriety through 

3 main industries; however, every industry that is involved in engineering has found it useful. 

 

CATIA has become a leader in product development software and may be exactly what is 

needed to overcome the shortcomings of CAD software. 
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Tool Bars 

 

Many standard toolbars are used in the different modes like sketcher mode operational mode 

etc, in CATIA software. Here we discuss about the tool bars used in sketcher with some 

examples. 

 

Sketcher Work Bench Tool Bars 

 

There are three standard tool bars found in the Sketcher Work Bench. The three toolbars 

are shown below. The individual tools found in each of the three tools are labeled to the right 

of the tool icon. Some tools have an arrow located at the bottom right of the tool icon. The 

arrow is an indication that there is more than one variation of that particular type of tool. The 

tools that have more than one option that are listed to the right of the default tool. To display 

the other tool options you must select and hold the left mouse button on the arrow as shown in 

Figure1.1. This will bring up the optional tools Select Arrow Optional tools. 

 

THE OPERATION TOOL BAR 

 

THE PROFILE TOOL BAR 
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THE CONSTRAINTS TOOL BAR 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Specify a Working Plane 

 

The next step is to create a 2 dimensional profile of the part. The Sketcher Work Bench is a 

two dimensional (planar) work area. To use the Sketcher Work Bench, you must specify which 

plane the profile is to be created on. Specifying, the plane can be done several different ways. 

 

ZX plane 
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MODIFYING THE PROFILE USING CHAMFER 

 

The Chamfer icon is also located in the Operations tool bar. This procedure assumes you know 

what a chamfer is. The steps required to create a chamfer are almost identical to creating a 

corner. Select the Chamfer icon. 

The command prompt at the bottom left hand of the screen, will prompt you with the following: 

“Select the first curve, or a common point”. For this exercise select line 5. The next command 

prompt will ask you to “Select the second curve”. 
 

 

Constraint 

 

This tool allows you to create individual constraints, one at time. You have already applied a 

constraint and may not even know it. The Anchor icon is a constraint. The values attached to 

the Chamfer and Corner is constraints. To apply Dimensional Constraints, complete the 

following steps: 

 

Select the Constraint icon. 

Select the line and/or Sketcher element to be constrained. 

The Sketcher element will turn green (constraint symbol) along with the appropriate dimension 

and box with the value in it. To re-locate the constraint value, select the value box and drag the 

mouse to the desired location. 

 

If the initial location of the constraint is not satisfactory re-select the dimension and drag and 

drop it at the new location. 

To edit the value of the constraint double click on the value box. This will bring up the 

Constraint Definition pop up window shown in. This window shows the existing value for the 

Sketcher element. This value can be edited by typing the new value over the existing value. 

Then select OK or hit the Enter key. The entities linked to the constraint will automatically be 

updated to the new value. 

 

If the constraint is between two different entities, such as lines, select the first line and then the 

second line. CATIA V5 will constrain the distance between the two entities. The constraint 

value will appear near the constraint to move the constraint value. For this lesson constrain 

your “L Shaped Extrusion” similar to the one shown in Figure. 
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Suggested Steps for practice exercises: 

 

1. Select the XY plane (the plane the profile will be sketched on). Enter the 

Sketcher Work Bench. 

2. Sketch the profile of the part. Hint: use the Profile tool. 

3. Anchor the lower left hand corner of the sketch. For anchoring a profile. 

4. Constrain the profile to match the dimensions given in the profile. 

5. Exit the Sketcher Work Bench, return to the Part Design Work Bench (the 

3D environment). Sketcher Work Bench and entering the Part Design Work 

Bench. 

6. Once in the Part Design Work Bench extrude the profile to the 

dimension. It’s Extrude or cut the profile. 

7. Finally save a part drawing. 

 
 

******************************* 
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TUTORIAL - 1 
 

Creating the “Swivel. CATPart” Using Multiple Sketches 

 

1.1 Start CATIA V5. 

1.2 Verify that you are in the Part Design Work Bench and the default Properties are 

set the way you want them such as Units. For this step, set the Units to mm. 

1.3 In the Specification Tree rename Part.1 to “Swivel”. 

1.4 Enter the Sketcher Work Bench using the ZX Plane as shown in figure 1.1 

 

ZX Plane 
 

 

 

 

 

 
 

Figure 1.1 

 

1.5 Create a circle at the coordinates (0,0) with a diameter of 25 mm as shown in figure 5.2 
 

 
Figure 1.2 

1.6 Exit the Sketcher Work Bench. Remember, this will put you back into the Part 

Design Work bench. 

1.7 Select the Pad tool. 

1.8 When the Pad Definition window appears, , select the More button. This will expand 

the Pad Definition window to show the Second Limit box. Figure 1.3 shows the Pad 

Definition window expanded to include the Second Limit. 
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Figure 1.3 

1.9 In the First Limit area enter “20mm” for the Length Box. Leave the Type box set at 
“Dimension”, as shown in figure 1.5. 

1.10 In the Second Limit area, enter ”20mm” for the Length box, as shown in figure 

1.5. 

1.11 Select the OK button. Notice that the circle has been extruded 1 inch in both 

directions, reference figure 1.4 
 
 

 
 

Figure 1.4 

1.12 Select the ZX Plane (figure 5.1) and enter the Sketcher Work Bench. 
1.13 Create another circle at the Coordinates (0,0) with a diameter of 18 (Figure 1.5). 
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Figure 1.5 
 

1.14 Exit the Sketcher Workbench. Select the Pad tool and select the More button to 

expand the Pad Definition window. 

1.15 Enter “40” as the First Length and “40” as the Second length. 

 

1.16 Select the OK button. The part should look similar the part shown in figure 1.6. 
 
 

Figure 1.6 
 

 

1.17 Select the YZ Plane (Figure 1.7) and enter the Sketcher Work Bench. 

YZ Plane 
 

 

 

 

 

Figure 1.7 
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1.18 Create a circle at the coordinates(0,0) with a diameter of 25mm(Figure1.2) 

1.19 Exit the Sketcher Work Bench and select the Pad tool. 

1.20 Select the More button from the Pad Definition window. 

1.21 Enter “20” for both the First and Second lengths. 

1.22 Select the OK button. The part should look similar the one shown in figure 1.8 
 

Figure 1.8 

1.23 Select the YZ Plane reference figure 1.7 
1.24 Enter the Sketcher Work Bench. 

1.25 Create a circle at the coordinates (0,0) with a diameter of 18mm, as shown in 

figure 1.5 

1.26 Exit the Sketcher Work Bench. 

1.27 Extrude the part using the Pad tool and More button. Enter “40” mm for both the 

First and Second Lengths. 

1.28 Select the OK button. At this point your part should look similar to the one shown 

in Figure 1.9. 
 

Figure 1.9 

 

Save the part as “Swivel.CATPart”. 
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TUTORIAL - 2 
 

 

Creating The “Top U-Joint” Using Multiple Sketches 

 

2.1 The “Top U-Joint” part is a new and completely separate part from the “Swivel” part 

you just created. Since the “Top U-Joint” part is a new part, you will need to go to 

the file option in the top left pull down menu. Select New. 

2.2 Selecting the Part option automatically puts you in the Part Design Work Bench. 

2.3 Select the YZ Plane, shown in Figure 2.1 
 

YZ Plane 
 

 

 

 

Figure 2.1 

2.4 Enter the Sketcher Work Bench. 

2.5 Sketch the Profile shown in Figure 2.2 

2.6 Constrain the profile as shown in Figure 2.2 

 
Figure 2.2 
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2.7 Exit the Sketcher Work Bench 

2.8 Use the Pad tool to extrude the profile 40mm. Your part should look similar to the 

one shown in figure 2.3 
 

Figure 2.3 

 

2.9 The next step is to create a 40mm diameter rounded edge on the bottom of both legs. 

This process can simplified by using the Tritangent Fillet tool. By default the 

Tritangent Fillet tool will be a sub option under the Edge Fillet tool . 
 

Select the Tritangent Fillet tool. 
 

 

2.10Selecting the Tritangent Fillet tool will 

bring up the Tritangent Fillet Definition 

window (Figure 2.4). The first box is the 

Faces To Fillet box. This box allows you 

to select two faces to be joined with a fillet. 

The second box is Face To Remove box. 

This box allows you to select the face that 

will be removed and replaced with the 

fillet. Figure 2.4 

2.11Select the front and back surfaces as the Faces to Fillet on the “Top U-Joint”, as 

shown in Figure 2.5 
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Select back 

surface 

 

 
Select front 

surface 

 

 

 
Figure 2.5 

2.12Select the bottom surface of the right leg. This surface joins the front and back 

surfaces. It is the Face to Remove, as shown in figure 2.6 

Figure 2.6 Figure 2.7 
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2.13 Select the OK button. The bottom surface selected will be removed and replaced 

with a radius. The radius will be the same size as the length of the surface it 

replaced, reference Figure 2.7. 

 

2.14Repeat steps 2.9 thru 2.13 to create the 

radius on the other leg. With the radii 

created on both legs, the part should look 

similar to the one shown in figure 2.8 
 

 

 

 

2.15To put the 18mm diameter hole in the two 

leg of the part, multi select the edge and 

surface shown in figure 2.8 
 

 
 

 

 

Edge 
 

Surface 

Figure 2.8 

 

2.16Select the Hole tool. When the Hole Definition Window appears, enter “18 mm” for 

the Diameter box and select “Up To Last” as the Hole Type. This will create the Hole 

in both legs at the same time. Select OK to create the hole. Your part should look 

similar to the one in Figure 2.9. 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 2.9 
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2.17The next step is to create the shaft on the top of the “Top U-Joint”. To accomplish 

this you will need to create a Plane that will represent the top of the shaft. This Plane 

is where you will create the sketch for the shaft. 

 

2.18Select the Plane tool from the Reference element tool bar and with the Plane 

Definition window set   to “Offset from Plane”, create a plane 150mm from the XY 

Plane as shown in Figure  2.10 
 

 

Figure 2.11 

. Figure 2.10 
 

2.19 Select the new Plane and enter the Sketcher Work Bench. 

2.20 Create a Circle, with a radius of 20mm and Constrain it as shown in figure 2.11 

2.21Exit the Sketcher Work Bench and extrude the circle down to the top surface of 

the “Top U-Joint” as shown in figure 2.12 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 2.12 
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2.22 Add a 2mm Chamfer to the top edge of the shaft as shown in figure 2.13 

2.23 Add a 5mm radius Fillet to all of the exterior edges of the solid as shown in Figure 

2.13 

2.24The “Top U-Joint” has now been created. Rename Part.1 in the Specification 

Tree to “Top U-Joint” 

2.25 Save the part as ‘Top U-Joint.CATPart.” 
 

 

 

 

 

 

Fillets 

Chamfer 
 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

Figure 2.13 
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TUTORIAL – 3 

 
Creating the “Bottom U-Joint” using Boolean Geometry. 

 

The third and last part you will create in this lesion is the Bottom U-Joint; The Bottom U- 

Joint is identical to the Top U-Joint. In industry you would create the Bottom U-Joint as 

efficiently as possible, which would be by duplicating the Top U-Joint. Since it is this 

books objective to show you how to step will use another method of creating the Bottom 

U-Joint. At the moment this may not be the most efficient method, but it will help you be 

a more efficient and knowledgeable CATIA V5 user. The method still has solids using 

Boolean geometry. The following instructions step you through the process of creating 

the Bottom U-Joint using Boolean Operations. 

3.1 Start a new part. rename it to Bottom U-Joint. 
3.2 Select the ZX Plane and enter the Sketcher Work bench. 

3.3 Create a rectangle of 80mm x 85mm in the Sketcher Work Bench . 

3.4 Exit the Sketcher Work Bench and extrude the box 40mm as shown in figure 3.1 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3.1 

3.5 Select the Insert tab from the top pull down menu as 

shown in figure 3.2 

 

3.6 From the Insert window, select the Body option. This 

will insert a new body into the Specification Tree 

(Figure 3.3). The purpose of this step will be explained 

later. 

 

3.7 Select the front surface of the box as shown in figure 

3.4 and enter the Sketcher Work Bench. Selecting the 

surface is the same as selecting a plane; the selection is 

where the sketch will be created. 

 

Figure 3.2 
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3.8 Sketch the profile shown in figure 3.5 CATIA V5 will allow you to Constrain the 

new sketch to the edges of the existing box (Sketch.1) as shown in figure 3.5 
 

 

 
 

Figure 3.3 Figure 3.4 
 

Figure 3.5 

3.9 Exit the Sketcher Work Bench and select the Pad tool. 

3.10In the Pad Definition window, select the More button. Figure 3.6 shows the Pad 

Definition window already expanded. 

 

 

 
Select 

this 

face 
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Figure 3.6 

 
 

3.11In the First Limit box, for the Length, enter “45mm” as shown in figure 3.6 

3.12In the Second Limit box, for the Length enter “.5mm” as shown in figure 3.6. Select 

the OK button. The extruded solid should look similar to the one shown in figure 3.7. 

if the solid was extruded in the wrong direction you may need to hit the Reverse 

Direction button to reverse the direction of the extrusion. 
 
 

 

Figure 3.7 

3.13Select the branch, Body.2 from the Specification Tree. This should highlight indicating 

it has been selected. The corresponding solid on the screen Body.2 will also highlight. 

If Body.2 is not selected, the following steps will not work. 

3.14 Select the Edit tab from the top pull down menu as shown in figure 3.8 

3.15 Select the body.2 Object from the bottom of the edit window Figure 3.8. 

Pad.1 

Pad.2 
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Figure 3.8 
 

 

 

 

3.16Select Remove from the list of Boolean Operations as shown in figure 3.8. this will 

remove the second profile from the first profile. Reference figure 3.9. selecting the 

Insert, Boolean Operation, Remove option will give you the same result. 

Figure 3.9 

 

3.17Create a 40mm radius Fillet on the bottom two edges of the par. Reference figure 3.10 
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Figure 3.10 

 

 

 

3.18 By using step 2.9 thru 2.23 then your can construct part, which will be like fig 3.11. 
 

Figure 3.11 

3.19If your part looks similar the one shown in figure 3.11, you are ready to save your 

newly created CATPart. Save the part as Bottom U-Joint.CATOPart. 
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EX. NO. 1 2D Geometry- Splines 

 
DATE: 

 

 

 

 

 
AIM: 

 

Preparation of 2D model using CATIA V5.18 software 

 

 
 

TOOLS USED: 

 

Pad, Pocketing etc., 

 

 
 

PROCEDURE: 

 

1. Click the Sketcher icon to start the Sketcher workbench. 

 

2. Select XY, YZ, ZX plane to define the sketch plane, now the Sketcher workbench 

isdisplayed, it contains the tools needed for sketching any profile. 

3. Select the profile and draw the part which is given in the model. 
 

4. Using Constraint command the dimensions are modified as per the given model. 

 

 

 

 

 

 

 

 

 

 

 

RESULT: 

 
Thus the given 2D model as per the drawing is modelled using CATIA V5.18 software. 
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EX. NO. 2 Surface Modeling- NURBS 

 
DATE: 

 

 

 

 

 
AIM: 

 

Preparation of surface model using CATIA V5.18 software 

 

 
 

TOOLS USED: 

 

Pad, Pocketing etc., 

 

 
 

PROCEDURE: 

 

1. Click the Sketcher icon to start the Sketcher workbench. 

 

2. Select XY, YZ, ZX plane to define the sketch plane, now the Sketcher workbench 

is displayed, it contains the tools needed for sketching any profile. 

3. Select the profile and draw the part which is given in the model. 
 

4. Using Constraint command the dimensions are modified as per the given model. 

 

5. Exit the Sketcher workbench, click Pad and give the thickness for the part. 

 

6. Select the face to define the work plane and draw the second element. 

 

 

 

 

RESULT: 

 
Thus the given surface model as per the drawing is modelled using CATIA V5.18 software. 
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EX. NO. 3 Solid Modelling 

 

 
DATE: 

 

 

 

AIM: 

 

Preparation of solid model using CATIA V5.18 software 

 

 
 

TOOLS USED: 

 

Pad, Pocketing etc., 

 

 
 

PROCEDURE: 

 

1. Click the Sketcher icon to start the Sketcher workbench. 

 

2. Select XY, YZ, ZX plane to define the sketch plane, now the Sketcher workbench 

isdisplayed, it contains the tools needed for sketching any profile. 

3. Select the profile and draw the part which is given in the model. 
 

4. Using Constraint command the dimensions are modified as per the given model. 

 

5. Exit the Sketcher workbench, click Pad and give the thickness for the part. 

 

6. Select the face to define the work plane and draw the second element. 

 

7. Using Pocket command material is removed and the final model is created. 
 

 

 

 

 

 

RESULT: 

 
Thus the given solid model as per the drawing is modelled using CATIA V5.18 software. 
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EX. NO. 4 Preparing solid model for analysis 

 
DATE: 

 

 

 

AIM: 

 

Preparation of solid model using CATIA V5.18 software for analysis 

 

 
 

TOOLS USED: 

 

Pad, Pocketing etc., 

 

 
 

PROCEDURE: 

 

1. Click the Sketcher icon to start the Sketcher workbench. 

 

2. Select XY, YZ, ZX plane to define the sketch plane, now the Sketcher workbench 

is displayed, it contains the tools needed for sketching any profile. 

3. Select the profile and draw the part which is given in the model. 
 

4. Using Constraint command the dimensions are modified as per the given model. 

 

5. Exit the Sketcher workbench, click Pad and give the thickness for the part. 

 

6. Select the face to define the work plane and draw the second element. 

 

7. Using Pocket command material is removed and the final model is created. 
 

8. Select Save As tab from file menu and save the as IGS/ STEP file format for analysis 

 

 

 
 

 

 

RESULT: 

 
Thus the given 3D model as per the drawing is modelled using CATIA V5.18 software. 
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STUDY OF ANALYSIS AND ITS BENEFITS 
 

Some Basic Concepts 

The finite element method (FEM), or finite element analysis (FEA), is based on the idea of building 

a complicated object with simple blocks, or, dividing a complicated object into smaller and 

manageable pieces. 

 
Why FEA? 

Computers have revolutionized the practice of engineering. Design of a product that used to be 

done by tedious hand drawings has been replaced by computer-aided design (CAD) using 

computer graphics. Analysis of a design used to be done by hand calculations and many of the 

testing have been replaced by computer simulations using computer-aided engineering (CAE) 

software. Together, CAD, CAE, and computer-aided manufacturing (CAM) have dramatically 

changed the landscape of engineering. 

Among all the computational tools for CAE, the FEM is the most widely applied method or one 

of the most powerful modern “calculators” available for engineering students and professionals.  

FEA provides a way of virtually testing a product design. It helps users understand their designs 

and implement appropriate design changes early in the product development process. The adoption 

of FEA in the design cycle is driven by market pressure since it brings many benefits that will help 

companies make better products with reduced development costs and time-to- market. 

 
Finite Element Applications in Engineering 

The FEM can be applied in solving the mathematical models of many engineering problems, from 

stress analysis of truss and frame structures or complicated machines, to dynamic responses of 

automobiles, trains, or airplanes under different mechanical, thermal, or electromagnetic loading. 

There are numerous finite element applications in industries, ranging from automotive, aerospace, 

defense, consumer products, and industrial equipment to energy, transportation and construction, 

as shown by some examples in Table. The applications of the FEA have also been extended to 

materials science, biomedical engineering, geophysics, and many other emerging fields in recent 

years. 
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FEA with ANSYS Workbench 

Over the last few decades, many commercial programs have become available for conducting the 

FEA. Among a comprehensive range of finite element simulation solutions provided by leading 

CAE companies, ANSYS® Workbench is a user-friendly platform designed to seamlessly integrate 

ANSYS, Inc.’s suite of advanced engineering simulation technology. It offers bidirectional 

connection to major CAD systems. The Workbench environment is geared toward improving 

productivity and ease of use among engineering teams. It has evolved as an indispensible tool for 

product development at a growing number of companies, finding applications in many diverse 

engineering fields 

 
A General Procedure for FEA 

To conduct an FEA, the following procedure is required in general: 

 Divide the CAD/geometric model into pieces to create a “mesh” (a collection of elements 

with nodes) 

 Describe the behavior of the physical quantities on each element. 

 Connect (assemble) the elements at the nodes to form an approximate system of 

equations for the entire model. 

 Apply loads and boundary conditions (e.g., to prevent the model from moving). 

 Solve the system of equations involving unknown quantities at the nodes (e.g., the 

displacements). 

 Calculate the desired quantities (e.g., strains and stresses) at elements or nodes. 

 
 

In commercial FEA software, this procedure is typically rearranged into the following phases: 

 Preprocessing (build FEM models, define element properties, and apply loads and 

constraints) 

 FEA solver (assemble and solve the FEM system of equations, calculate element results) 

 Postprocessing (sort and display the results) 
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Overview of ANSYS Workbench 

ANSYS Workbench is a simulation platform that enables users to model and solve a wide range of 

engineering problems using the FEA. It provides access to the ANSYS family of design and analysis 

modules in an integrated simulation environment. This section gives a brief overview of the 

different elements in the ANSYS Workbench simulation environment or the graphical-user interface 

(GUI). Readers are referred to ANSYS Workbench user’s guide for more detailed information. 

 
The User Interface 

The Workbench interface is composed primarily of a Toolbox region and a Project Schematic 

region. The main use of the two regions is described next. 
 

 

Figure: ANSYS Workbench user interface. 

 
 

The Toolbox 

The Toolbox contains the following four groups of systems: 

Analysis Systems: Predefined analysis templates to be used to build your project, including static 

structural, steady-state thermal, transient thermal, fluid flow, modal, shape optimization, linear 

buckling, and many others. 
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Component Systems: Component applications that can be used to build or expand an analysis 

system, including geometry import, engineering data, mesh, postprocessing, and others. 

Custom Systems: Coupled-field analysis systems such as fluid solid interaction, prestress modal, 

thermal-stress, and others. 

Design Exploration: Parametric optimization studies such as response surface optimization, 

parameters correlation, six sigma analysis, and others. 

 
The Project Schematic 

A project schematic, that is, a graphical representation of the workflow, can be built by dragging 

predefined analysis templates or other components from the Toolbox and dropping them into the 

Project Schematic window. “Drag” here means to move the mouse while holding down the left  

mouse button, and “drop” means to release the mouse button. 

 
To build a project for static structural analysis, for instance, drag the Static Structural template 

from the Toolbox and drop it into the rectangular box that appears in the Project Schematic 

window. A standalone analysis system that contains the components needed for static structural 

analysis is added to the project schematic as shown in Fig. The system consists of seven individual 

components called cells. 

 
Alternatively, a standalone analysis can be created by double-clicking. For example, double- click 

the Steady-State Thermal template from the Toolbox, and an independent 
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Figure: Defining standalone analysis systems in the project schematic: (a) a standalone system; 

(b) two independent standalone systems; (c) moving a system in a top-bottom configuration; and 

(d) moving a system in a side-byside configuration. 

 
 

Steady-State Thermal system will be placed in the default location below the existing Static 

Structural system. 

A system can be moved around another system in the project schematic. To move a system, click 

on the header cell (i.e., the cell titled Steady-State Thermal for the thermal system) and drag it to 

a new place. Once you drag the header cell, dashed rectangles appear for the possible new locations 

to drop the system. This is illustrated in Fig c and d for two systems with initial top– bottom and 

side-by-side configurations, respectively. 
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To delete a system, click on the down arrow button at the upper left corner of the system from the 

Project Schematic window, and then choose Delete from the drop-down context menu. 

 
In somecases, a project may contain two or more analysis systems that share data. For example, a 

downstream modal analysis may use the same material, geometry, and model data from the 

preceding structural analysis. To build such a project, create a standalone system for Static 

Structural analysis. Then, drag the Modal analysis template from the Toolbox and drop it onto 

the Model cell of the Static Structural system. Immediately before the subsequent system is 

dropped, bounding boxes will appear on the Engineering Data, Geometry, and Model cells of the 

first system, as shown in Fig a. After the system is released, a project including two linked systems 

is created, as shown in Fig b, where the linked cells indicate data sharing at the Model and above 

levels. 

 
 

Figure: Defining linked analysis systems in the project schematic: (a) dropping the second 

(subsequent) system onto the Model cell of the first system to share data at the model and above 

levels; (b) two systems that are linked. 

 
Working with Cells 

Cells are components that make up an analysis system. You may launch an application by double-

clicking a cell. To initiate an action other than the default action, right-click on a cell to view its 

context menu options. The following list comprises the types of cells available in ANSYS 

Workbench and their intended functions: 

Engineering Data: Define or edit material models to be used in an analysis. 

Geometry: Create, import, or edit the geometry model used for analysis. 
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Model/Mesh: Assign material, define coordinate system, and generate mesh for the model. 

Setup: Apply loads, boundary conditions, and configure the analysis settings. 

Solution: Access the model solution or share solution data with other downstream 

systems. 

Results: Indicate the results availability and status (also referred to as postprocessing). 

 
 

As the data flows through a system, a cell’s state can quickly change. ANSYS 

Workbench provides a state indicator icon placed on the right side of the cell. 

Table describes the indicator icons and the various cell states available in 

ANSYS Workbench. For more information, please refer to ANSYS Workbench 

user’s guide. 

 
The Menu Bar 

The menu bar is the horizontal bar anchored at the top of the 

Workbench user interface. It provides access to the following functions: 

File Menu: Create a new project, open an existing project, save the current project, and so 

on. 

View Menu: Control the window/workspace layout, customize the 

toolbox, and so on. Tools Menu: Update the project and set the 

license preferences and other user options. Units Menu: Select the 

unit system and specify unit display options. 

Help Menu: Get help for ANSYS Workbench. 
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     Ex. No :5      STRESS ANALYSIS OF CANTILEVER BEAM 
     Date     :  

 

 
 

Problem Description 
 

 

 
This is a simple, single load step, structural analysis of a cantilever beam. The left side of the 

cantilever beam is fixed while there is a distributed load of 20N/m. The objective of this problem 

is to demonstrate a simple ANSYS Workbench problem with a textbook solution: finding Von 

Mises’ stresses and total deflection throughout the beam. The beam theory for this analysis is  

shown below: 
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Workbench Analysis System 

Opening Workbench 

1. On your Windows Desktop click the Start button. 

2. Under Search Programs and Files type “ANSYS” 

3. Click on ANSYS Workbench to start workbench. This step may take time. 
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Static Structural Analysis 
 

1. As you open ANSYS you can see the entire array of problems on the left had side this 

software can help you solve. The problem at hand is a Static Structural problem. Double 

click Static Structural (ANSYS) to open the task manager for your problem set in the 

Project Schematic area. 

2. ANSYS allows you to build on each problem, so it is smart to name each project. At the 

bottom of the task manager you will see Static Structural (ANSYS), double click this to 

change the name. For this problem choose “3D Cantilever beam.” 

 

 

1 

 

 

 

 

2 
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WARNING : Do not delete or change the Structural Steel, j ust another material 

Engineering Data 

To begin setup for your cantilever beam, double click or right click on Engineering Data and 

click edit.  This will bring up another screen. 
 

This new window will allow you to alter the material properties of your cantilever beam. Under 

Outline of Schematic A2: Engineering Data, it shows click here to add a new material, this 

menu allows you to input the material of your cantilever beam, double click and type Aluminum. 
 

 

Now expand Linear Elastic by double clicking on or on the plus 

symbol shown.  

Double click on Isotropic Elasticity to give the material the same properties across the beam. 

This action brought up a new table on the right; this allows us to add necessary properties. As 

show on the top right of the screen in Table of Properties Row 2: Isotropic Elasticity: 

 

 

 

 

 

 
 

WARNING Do not delete or change the Structural Steel, just another material. 
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WARNING: Make sure to DELETE the Temperature entry after property input before 

continuing! Failure to do so will lead to errors later. 

2 

3 

1. Click in Temperature and type 25 

2. Click in Young's Modulus and type 70E9 or 7E10 

3. Click in Poisson's Ratio and type 0.33 
 
 

 

 
 

 

After filling in the properties, this concludes the Engineering Data, to return to the project 

schematic area, click on seen on the upper tab. 

Geometry 

Base Geometry 

1. Go to Workbench -> Project Schematic -> Geometry and double click. This will open 

a new window for ANSYS Design Modeler where the Geometry will be created. 

Note: Select meters and hit ok 

2. In the new window, click the  Display Plane icon to toggle the coordinate system. 

3. Go to Design Modeler -> Tree Outline -> right click on YZPlane. Click Look At to 

view the YZ plane. 

WARNING Make sure to DELETE the Temperature entry after property input before 

continuing! Failure to do so will lead to errors later 
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4. Go to Design Modeler -> Tree Outline -> Sketching 

5. Click on Rectangle and Click off Auto-Fillet: 

6. Bring your cursor into the workspace at point 0,0, over the origin until ‘P' appears 

directly above the origin. 

7. Click on the origin to place the lower left corner of our rectangle on the origin. 

8. Click on a point in the first quadrant to define the top right corner of our rectangle. The 

point is arbitrary as we will be fixing dimensions momentarily. 

8 
 

7 

6 

9. Go to Sketching Toolboxes -> Dimensions 

10. Click Horizontal to specify a horizontal dimension. 

11. Click the left and right faces of the rectangle in the sketch to specify that we will be 

dimensioning this horizontal length. A green line with a symbol should appear. 

12. Drag the green line above the sketch and click to set its location. 

13. Go to Detail View -> Dimension 1. In the first subcategory, replace the current 

dimension with 10. The units should populate automatically. 
 

9 
10 

12 

11 11 

13 

9 
10 

12 

11 11 

13 
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14. Go to Sketching Toolboxes -> Dimensions -> Vertical to specify the vertical 

dimension. 

15. Click the bottom and top faces of the sketch to specify the vertical dimension. A green 

line should appear. 

16. Drag the green line to the right of the sketch and click. 

17. Go to Detail View -> Dimension 2. Replace the value with 10. The units should populate 

automatically (meters). 
 

Now that we have modeled the base geometry, we will extrude it to create a 3D volume. 

Extrude Sketch 

1. Go to Main Toolbar -> and select Extrude 

2. Go to Modeling -> FD1, Depth (>0) -> enter in 110 

3. Go to Design Modeler -> Generate. 

4. To verify our geometry, look at the isometric view. Click the blue dot in the triad in the 

lower right corner of the screen to look at the isometric view. 

 

 

 

 

 

 

 
 

 

 

 

 

2 

14 
15 

16 

15 

17 
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Surface s Your 3D urface should look like this: 

 

 

 

Now that we have the geometry, we will mesh the beam using 3D Elements. 

 

Model 
 

Open ANSYS Mechanical 
 

1. out of Design Modeler. Don't worry, your work will be saved. 

2. Go to Workbench -> Project Schematic -> Model This will open ANSYS Mechanical 
 
 

2 

46



CATIA cadcamguru 

 

 
 

Material Assignment 
 

1. Go to Mechanical -> Outline -> Project -> Model -> Geometry -> Surface Body 

2. Under Mechanical -> Details of “Surface Body” -> Material -> Assignment, change 

Structural Steel to Aluminum. 

              Mesh 
 

1. Go to Mechanical -> Outline -> Project -> Model -> Mesh 

2. Go to Mechanical -> Details of ‘Mesh’ -> Sizing -> Element Size and change the value 

from Default to .5 m. This will give us 2 elements through the thickness of the beam. 

 

3 
1 

2 

1 

2 
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3. Click Mechanical -> Update. This may take some time. Your mesh should look as 

shown below: 

 

 

 

 

 

Setup 
 

You can perform the rest of your analysis for this problem in the ANSYS Mechanical window. 

The other options in the Workbench window will link you back to the same screen (i.e. Setup, 

Solution, Results) 

Fixed Support 
 

1. Go to Mechanical -> Outline -> right click Static Structural (A5) 

2. Go to Insert -> Fixed Support 
  

We are going to fix the elements at the left end of the beam. In order to do this, we will use the 

Edge tool to select the left edge. However, from the current orientation of the beam, it is difficult 

to select this surface. 

 
 

3. Using the  Rotate tool click on the graphic area and move the mouse to the right. 

This will cause the left end of the beam to be oriented in a manner that can be clicked                                                                           

1 

2 
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e in the 
will ope 

 

4. Using the Pan tool, click the graphic area and drag the left face to the center of the 

graphic window. Use the mouse scroll to zoom in on the left face 

 

 

 

 

 
 

5. Click the Edge tool. 

6. Go to Mechanical -> Outline -> Static Structural (A5) -> Fixed Support 

7. Run the cursor across the left end face. When it becomes red, click it to select it. 

8. Go to Mechanical -> Details of “Fixed Support” -> Geometry and select Apply 

 

 
Setup 

 

While in the Project Schematic double click Setup 

This will en a new window similar to Model Space 

 
 

Loads 

1. Click the x-axis icon to get a side view of the cantilever beam  

2. Click Fixed end On the tool bar, make sure vertex option is selected. 
3. Go to Mechanical -> Outline -> Static Structural (A5) -> Fixed Support 

4. Run the cursor across the left end face. When it becomes red, click it to select it. 

5. Click the left side of the geometry; this will add a green box to select the point. 

6. Right click 

7. Click insert, and 

8. This will add a fixed end to your cantilever beam in the work space. 

9. Point Load On the tool bar, change selection option to Edge: edge instead of 

vertex. 

10. Click on the geometry, this will highlight 

11. Right click 

12. click insert , and A table will appear “Details of Line Pressure” 

13. Under “Definition” you will see “Defined by”Change this to “Components” 

14. As shown, Y Component force is zero.  Change this to value to -20 

15. This will show your cantilever beam with a load applied as shown. Leave the Setup 

screen open this time. 
 

Pan 

Rotate 
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Solution 
 

Go to Mechanical -> Outline -> Project -> Model(A4) -> Static Structural (A5) -> 

Right Click Solution (A6) -> Insert -> Beam Tool 

 
Deformation 

Go to Mechanical -> Outline -> Project -> Model(A4) -> Static Structural (A5) -> 

Solution (A6) -> Beam Tool -> Insert -> Beam Tool -> Deformation -> Total 

 

Stress 
 

Go to Mechanical -> Outline -> Project -> Model(A4) -> Static Structural (A5) -> 

Solution (A6) -> Beam Tool -> Insert -> Beam Tool -> Stress -> Maximum Bending 

Stress 
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Now that our solvers have been defined, go to Mechanical -> Solve. The 

calculations in Workbench may take up to a minute to solve. 

 

 
Go to Mechanical -> Outline -> Project -> Model (A4) -> Solution (A6) -> Maximum 

Bending Stress 

Go to Details of “Maximum Bending Stress”-> Integration Point Results -> Display 

Option -> Change to Unaveraged 

Your Stress plot should look as shown below: 
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Go to Mechanical -> Outline -> Project -> Model(A4) -> Solution(A6) -> Total 

Deformation 

Your Von-Mises plot should look as shown below: 
 

Results 

Max Deformation Error According to equation , the theoretical max deflection is 7.16 mm. The 

percent error (%E) in our model can be defined as: 

 

               Max Equivalent Stress Error 

According to equation, the theoretical max equivalent stress is 66000 Pa. Using the same 

definition of error as before, we derive that our model has 6.3% error in the max equivalent 

stress. The reason for the elevated stress level is singularity resulting from Poisson’s effect at the 

fixed support. In the validation section, it is shown that with increased mesh size, the analytical 

answers for Max Equivalent stress are closely represented in nodes close to but not at the region 

where singularity occurs. The effect of singularity is also reduced with the implementation of 

higher order elements. 
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Validation 
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MODAL ANALYSIS OF STEPPED SHAFT 

     Ex. No : 6       

Date : 

 

 

INTRODUCTION 

Modal analysis is an important type of structural analysis and play an important role in vibration 

prediction of engineering structures. Every structure has its number of natural frequencies starting 

from first, second to infinite. Modal analysis is used to predict these natural frequencies. These 

natural frequencies are used to avoid resonance as it occurs if applied load frequency matches with 

one of the natural frequencies of vibrating body. 

 
PROBLEM DESCRIPTION 

The geometric dimension of stepped shaft has been shown in fig-1. A 3D model has been shown 

in fig-2. 

 
 

Fig1 
 

Fig 2 

Step-1. Open Ansys workbench and double click on modal analysis module from toolbox, it 

appears in Project schematic, fig-3. 

Step-2. In project Schematic right click Geometry>Import Geometry>Browse the path where 

downloaded IGS file of stepped shaft is located, fig-4. 
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Fig 3 

 

 

Fig 4 

Step-3: Click File>Save, write File Name as "stepped shaft" and press Save. 

Step-4: Right click on Model>Edit, mechanical window opens now. 

Step-5: Click on mesh in Outline tree and go to Details of mesh and click '+' sign on the left of 

Sizing and change relevance center from Coarse to fine, fig-5. 
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Step-6: Right click on mesh and click on Generate mesh, fig-6. Meshing of shaft will be 

generated, fig-7. 

 

Fig 5 

Fig 6 
 

 

Fig 7 

Step-7: Click on Face selection button to select faces, fig-8. From outline right click 

Modal>Insert>Fixed Support, fig-9. Now select left end face it turns green, fig-10 and "Details 

view of support" click apply, fig-11. 
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Fig 8 
Fig 9 

 

 

 

 

 

 
 

 
 

 

 
 

Fig 10 

Fig 11 

 

 

 

 

Step-8: Click on analysis settings, that is present under Modal in outline. Go to "Details of 

analysis settings" and set Max Modes to Find to 6, fig-12. Click File>Save. Right click 

Solution>Insert>Deformation>Total and set Mode to 1 in "Details of Deformation"., Fig-13. 
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Fig 12 Fig 13 

Step-9: Similarly repeat Step-9 again to set mode 2, 3, and so on up to 6. 

Step-10: Right click on Solution>Solve and wait until solution status complete. 

Step-11: Reduce the view scale from top right corner to 1.7e-2, fig-14. 

Step-12: Click on Total Deformation under Solution in order to see contours for any Mode, 

fig-16. Frequency Table is also available from Tabular Data, Fig-15. 

 
 

  

Fig 14 Fig 15 
Fig-16: Mode 4 Shape 
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Result: 

So in this modal analysis, we have found natural frequencies using Ansys workbench. 
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      TRANSIENT ANALYSIS OF A SPRING MASS DAMPER SYSTEM USING ANSYS 

 

Ex: No: 7  

Date:  
 

Problem: 
 

Show the effect of damper and its damped oscillation when the mass m is displaced from its 
equilibrium position and left free for its damped oscillation (as shown in Fig.7). Take spring stiffness (K) 
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= 100 N/m, and mass (m) = 10 kg. Show the response of the following cases, when damping coefficient 
(i) C = 0, (ii) C = 0.1 of Cc (iii) C = Cc, (iv) C = 1.2 of Cc where Cc = critical damping coefficient = 
2√𝐾 ∗ 𝑚 
ANSYS Analysis Procedure: 

 

1. Utility menu bar: select File > Change Title: 

Enter the title (Give title of your choice) in the window appeared and click 'OK'. 

2. Main menu bar: Preferences > Structural> Click 'OK' 

3. Main menu bar: Preprocessor>Element Type > Add/Edit/Delete > in the window click 

Add>select combination(sub window 1)> spring damper14(sub window 2)> Click 'OK' 

Main menu bar: Preprocessor>Element Type > Add/Edit/Delete > in the window select “type1 

COMBIN14> click on “OPTIONS” > K2 options (enter) longitude UY DOF 

Main menu bar: Preprocessor>Element Type > Add/Edit/Delete > in the window click 

Add>selectsturcutral mass(sub window 1)>3D mass 21 (sub window 2)> Click 'OK' 

Main menu bar: Preprocessor>Element Type > Add/Edit/Delete > in the window select “type1 

COMBIN14> click on “OPTIONS” > K3options (select) 2-D w/o rot iner> click ‘OK’ 

4. Main menu bar: Preprocessor>Real Constants > Add/Edit/Delete> Click Add... and select 

‘COMBIN14'> Click on 'OK'. The Real Constants window will appear> input K = 

100>CV1=10> Click on 'OK'. 'Set 1' now appears in the dialog box. 

Select Mass21'> Click on 'OK'. The Real Constants window will appear> input mass = 10 Click 

on 'OK'. 'Set 2' now appears in the dialog box. Click on 'Close' in the 'Real Constants' window 

5. Main menu bar: Preprocessor>Modeling> Create >nodes> In Active CS, in the create nodes in 

active coordinate system, type key point no. and its coordinates. Here 

node x y z 

1 0 0 0 (Click ‘apply’) 

2 0 -1 0 (Click ‘OK’) 

6. ANSYS Main Menu: Preprocessor>Modeling>Create>Nodes>In Active CS> type the 
following in the Create Nodes in the Active Coordinate System window 

Node number X Y Z 

1 0 0 0 (Click Apply) 
2 1 0 0 (Click OK) 

7. ANSYS Main Menu: Preprocessor>Modeling>Create>Element>Auto Numbered> Through 
Nodes, in the Elements from Nodes window, type ‘1’ (Enter) and type ‘2’ (Enter) and Click 
‘OK’. 

8. ANSYS Main Menu: Solution >Define Loads > Apply > Structural > Displacement >On 

nodes>Type node 1 in the Apply U, ROT on Nodes window click ‘Apply’, then select ‘UX’ in the 

Apply U, ROT on Nodes window (Check Apply as field with ’ Constant value’ and VALUE = 0), 
then Click ‘OK’ 

9. ANSYS Main Menu: Solution >Define Loads > Apply >Initial Condition>Define>in the 

Define Initial Conditions window type ‘2’ and Click ‘Apply’. Then in the Define Initial 

Conditions window, in the DOF to be specified field select ‘UX’and in the Initial value of DOF 
type ‘-1’.Click ‘OK’. 

 

10. ANSYS Main Menu: Solution >Analysis Type>New Analysis>Transient>Click 
‘OK’>Click ‘OK’. 

11. ANSYS Main Menu: Solution >Analysis Type> Sol’n controls >Transient>in the Full 
Transient Options Tick Transient effects and in the Algorithm Field>select HHT algorithm. 
Click ‘OK’. 
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12. ANSYS Main Menu: Solution >Analysis Type> Sol’n controls >Nonlinear>Click Set 

Convergence Criteria>Replace>Tolerance about VALUE>0.0001> OK>Close>Close>OK 

13. ANSYS Main Menu: Solution >Analysis Type> Sol’n controls >Basic>in the Write Items to 

Result field, Tick User selected>Nodal DOF solution and in the Frequency field> select Write 

every Nth Substep, then in the Time Control field >in the Time at end of load step type 
‘0.0002’ and Tick No. of Substeps and type 5 in the No. of Substeps field. Click ‘OK’ 

14. ANSYS Main Menu: Solution>Load step options>Output Ctrls> Solu Printout>in the Solu 
Printout Controls window, in the Item for Printout Control field select ‘Basic quantities’ and in 
the Print frequency field, Tick None. Click ‘OK’. 

15. ANSYS Main Menu: Solution>Load step options>Load step opts>Write LS file> Click 
‘OK’ 

16. ANSYS Main Menu: Solution>Load step options >Output ctrls >Solu printout>>in the 

Solu Printout Controls window, in the Item for Printout Control field select ‘Basic quantities’ 
and in the Print frequency field, Tick Last Substep. Click ‘OK’. 

17. ANSYS Main Menu: Solution >Analysis Type> Sol’n controls >Basic>in the Time Control 

field>in the Time at end of load step type‘10’ and type 40 in the No. of Substeps field. Click 
‘OK’. 

 

18. 

 

ANSYS Main Menu: Solution>Load step options >Load step opts>Write LS file> Click 

‘OK’ 

19. ANSYS Main Menu: Solution>Solve>From LS file, in the Solve Load Step Files, in the 

LSMIN field, type ‘1’, in the LSMAX field, type ‘2’ and in the LSINC field, type ‘1’. Click 
‘OK’. 

20. ANSYS Main Menu: Time Hist Postpro >Close the window 

21. ANSYS Main Menu: Time Hist Postpro >Settings>Data>in the Data Settings window, in the 

TMIN field, type ‘0.003’, in the TMAX field, type ‘10’ and in the TINC field, type ‘1’. Click 
‘OK’. 

22. ANSYS Main Menu: Time Hist Postpro >Define Variable>Add> in the Add Time-History 

Variable window, Tick Nodal Solution. Click ‘OK’,   then in the Define Nodal Data window, in 

the NVAR field, type ‘2’, in the NODE field, type ‘2’, and in the User specified Label field, type 
‘2UX’. Then in the Item, Comp Data item, Pick DOF solution (sub window 1) and 
Translation UX (sub window 2). Click ‘OK’, 

23. ANSYS Main Menu: Time Hist Postpro >Graph Variables>in the Graph Time- History 
Variable window, in the NVAR1 field, type ‘2’. Click ‘OK’, 

24. ANSYS main window shows the corresponding output graph. 

25. With the above said step, Change the Damping Coefficient (in Step 5) as C = 0 (no damper), 

6.32 (under damped), 63.2 (critically damped), and 75.84 (over damped). See the 
corresponding output graph in the ANSYS main window. 

 

 

RESULT: 
Thus the transient analysis of a spring mass damper system has been analyzed. 
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INTRODUCTION TO CNC 
 

 

DEFINITION OF CNC 
 
 

“A system in which the actions are controlled by direct insertion of numerical data at some 

point .The system must automatically interpret at least some portion of this data” 

 
 

WHY IT IS CALLED AS CNC? 
 

Since the information required to actuate and control slides of the machine are coded 

numerically, this technology came to be known as Numerical Control. 

 
 

WHAT IS CNC? 
 

CNC is acronym for Computer Numerical Control. 
 

A dedicated computer is used to perform all the basic NC functions. The complete part 

programme to produce a component is input and stored in the computer memory and the 

information for each operation is fed to the machine tools. The program can be stored and 

used in future 

 
 

AXIS IN CNC MACHINES 
 
 

THE BASIS OF AXIS IDENTIFICATION IS THE 3-DIMENSIONAL CARTESIAN 

CO-ORDINATE SYSTEM AND THREE AXIS OF MOVEMENT ARE 

IDENTIFIED AS X,Y AND Z AXIS 

 
 

Z AXIS. 
 

Z- Axis The Z Axis of motion is always the axis of the main spindle of the machine.It doses 

not matters whether the spindle carries the work piece or the cutting tool . On vertical 

machining centers Z axis is vertical and on horizontal machining center and turning centers 

Z axis is horizontal 

 
 

Positive Z Movement is away from the spindle 
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X-Axis The axis is always horizontal and is always parallel to the work holding surface. 

Positive X Axis movement is identified as being to the right, when looking from the spindle 

towards its supporting column. 

 
 

Y- Axis The axis is always at right angle to both X-Axis and Z-Axis 
 
 
 

Rotary axis .The rotary motion about the X,Y and Z-Axis are identified by A,B,C 

respectively .Clockwise is designated as +VE. .Positive rotation is identified looking in x 

,y and z direction respectively 

 
 
 
 

AXIS IN CNCLATHE  
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AXIS IN MILLING MACHINE 

 
A milling machine has 3 axes of movement identified by X, Y & Z axes  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The maximum work piece dimensions correspond to the possible traversing path of the 
tool in the particular axis. 

 

AXIS IN MILLING MACHINE  
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ZERO POINTS REFERENCE POINT  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The reference point R serves for calibrating and for controlling of measuring systems of 
the slides and tool traverses. The position of the reference point is accurately predetermined 
in every traverse axis by the trip dogs and limit switches. Therefore, the reference point 
coordinates always have the same, precisely known numerical value in relation to the 
machine zero point. 

 
After initiating the control system, the reference point must always be approached from all 

axes to calibrate the traverse measuring system. 
 
 
 

DIMENSION SYSTEM 

 
Dimensional information in a work piece drawing can be stated in two ways Absolute 
Dimension System and Incremental Dimension System. 
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Absolute Dimension System 

 
Data in absolute dimension system always refer to a fixed reference point. This point has 
the function of a coordinate zero point. The dimension lines run parallel to the coordinate 
axes and always start at the reference point. Absolute dimensions are also called as 
'Reference dimensions'  
Incremental Dimension System 

 
When using Incremental Dimension system, every measurement refers to a previously 
dimensioned position Incremental dimensions are distance between adjacent points. These 
distances are converted into incremental coordinates by accepting the last dimension point 
as the coordinate origin for the new point. This may be compared to a small coordinate 
system, i.e., shifted consequently form point to point (P1..P2..through P9). Incremental 
dimensions are also frequently called 'Relative dimensions' or 'Chain dimensions'. 

 

 

DIMENSION SYSTEM 
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STUDY OF ISO CODES 

 

CNC MILLING 
 
 
 
 

AIM: To study various CNC Milling codes and addresses 
 

 

PREPARATORY FUNCTIONS (G CODES) 
 

A number following address G determines the meaning of the command for the 

concerned block. G codes are divided into the following two types 

 
 

Type Meaning 
  

One-shot G code The G code is effective only in the block in 

 which it is specified 
  

Modal G code The G code is effective until another G 

 code of the same group is specified 
  

 
 

LIST OF G CODES   
G00: Point to point positioning (Rapid traverse) 

 
G01: Linear interpolation 

 
G02: Circular interpolation clockwise 

 
G03: Circular interpolation counter clockwise 

 
G04: Dwell, Exact stop 

 
G17: X Y Plane selection 

 
G18: Z X plane selection 

 
G19: Y Z Plane selection 

 
G20: Input in inch 

 
G21: Input in metric (mm) 

 
G28: Return to reference point 

 
G40: Cutter compensation cancel 

 
G41: Cutter Compensation left 

 
G42: Cutter Compensation right 
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G43: Tool length compensation positive direction 
 

G44: Tool length compensation negative direction 
 

G49: Tool length compensation cancel 
 

G50: Scaling OFF 
 

G51: Scaling ON 
 

G54: Datum shift 
 

G68: Rotation ON 
 

G69: Rotation cancel 
 

G73: High speed Peck drilling cycle 
 

G74: L.H Tapping cycle 
 

G76: Fine Boring 
 

G80: Canned cycle cancel 
 

G81: Continuous drilling cycle, Stop boring 
 

G82: Continuous drilling cycle, Stop boring with dwell 
 

G83: Peck drilling cycle 
 

G84: R.H. Tapping cycle 
 

G85: Boring cycle with feed retraction 
 

G86: Boring cycle with rapid retraction 
 

G87: Back boring cycle 
 

G88: Boring cycle 
 

G89: Boring cycle with dwell & feed retraction 
 

G90: Absolute coordinates 
 

G91: Incremental coordinates 
 

G92: Set Datum 
 

G94: Feed per minute 
 

G95: Feed per revolution 
 

G98: Return to initial point in a canned cycle 
 

G99: Return to R point in a canned cycle 
 

G170, G171: Circular pocketing 
 

G172, G173: Rectangular pocketing 
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MISCELLANEOUS FUNCTIONS (M CODES) 
 

When a three digit figure is specified following address M, a 3-digit BCD code signal and 

a strobe signal are transmitted. These signals are used for ON/OFF control of a machine 

function such as tool change, spindle rotation change, coolant ON/OFF. One M code can 

be specified in one block. Selection of M codes for functions varies with the machine tool 

builder. 

 
 

LIST OF M CODES   
M00: Program stop 

 
M01: Optional (planned) stop 

 
M02: End of program 

 
M03: Spindle ON clockwise 

 
M04: Spindle ON counter clockwise 

 
M05: Spindle stop 

 
M06: Tool change 

 
M07: Coolant 2 ON 

 
M08: Coolant 1 ON 

 
M09: Coolant OFF 

 
M10: Vice open 

 
M11: Vice close 

 
M12: Synchronization code 

 
M13: Spindle clockwise and coolant ON 

 
M14: Spindle counterclockwise and coolant ON 

 
M19: Orientates Spindle 

 
M20: ATC arm IN (Towards spindle) 

 
M21: ATC arm out (Retracts from spindle) 

 
M22: ATC arm down 

 
M23: ATC arm up 

 
M24: Activates ATC draw bar 

 
M25: Releases draw bar 

 
M30: Program stop & rewind 
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M32: Rotates ATC clockwise 
 

M33: Rotates ATC counter clockwise 
 

M38: Opens the door 
 

M39: Closes the door 
 

M62: Output 1 ON 
 

M63: Output 2 ON 
 

M64: Output 1 OFF 
 

M65: Output 2 OFF 
 

M66: Wait input 1 ON 
 

M67: Wait input 2 ON 
 

M70: X mirror ON 
 

M71: Y mirror ON 
 

M76: Wait input 1 OFF 
 

M77: Wait input 2 OFF 
 

M80: X mirror OFF 
 

M81: Y mirror OFF 
 

M98: Sub program Call 
 
      M99: Sub program Exit
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Write a manual part program for machining the component shown in DWG.NO.2. Profile depth=1mm 
 
 

 
 

 

 
 

DWG.NO.2 

 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 100x100x10 MATERIAL: Aluminium 

PROGRAM NO:1002 DWG.NO:2 

 

Sl.No 

 

Operation 

 

Tool type 

 

Tool dia., mm 

Tool 

Station 

No. 

Tool 

length 

offset No. 

Spindle 

speed, rpm 

Feed, 

mm/min 

1 Contouring Slot cutter 5 1 1 1500 30-50 
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LINEAR MOTIONS 

EX.NO: 8 

DATE: 

  

AIM: 

To write a manual part program for machining the component shown in the DWG. NO.2 

 

MATERIAL REQUIRED: 

 

  

Material Size 

  

: Aluminium 

: Length 100mm, Width 100mm, Thickness 10mm 

  

 

PROGRAM: 

 

O0002 G21 G94 

G91 G28 X0 Y0 Z0  

M06 T01 

M03 S1500 

G90 G00 X25 Y25 Z5 

 G01 Z-1 F50 

G01 X75  

G01 Y75  

G01 X25  

G01 Y25  

G00 Z5 

G91 G28 X0 Y0 Z0 M05 

M30 

 

 

 

 

 

 

 

 

 

RESULT: 

 

Thus the manual part program was written to the given dimensions and executed in CNC milling. 
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Write a manual part program for Profile Milling operation for the component shown in DWG.NO.4. 
Profile depth=1mm  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

DWG.NO.4  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 100x100x10  MATERIAL: Aluminium  

PROGRAM NO:1004   DWG.NO:4    

     Tool  Tool 
Spindle Feed, 

Sl.No Operation 
 
Tool type Tool dia., mm Station 

 
length   

speed, rpm mm/min      No.  offset No. 

1 Contouring  Slot cutter 5 1  1 1500 30-50 
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CONTOUR MOTIONS 

EX.NO: 9 

DATE: 

AIM: 

To write a manual part program for contouring operation for the component shown in the DWG. NO.4 

 

 

MATERIAL REQUIRED  

 

Material :Aluminium  

Size : Length 100mm, Width 100mm, Thickness 10mm 
 

  

PROGRAM: 
 

O0004  

G21 G94 

G91 G28 X0 Y0 Z0  

M06 T01 

M03 S1500 

G90 G00 X50 Y70 Z5  

G01 Z-1 F30 

G01 X70  

G01 Y50  

G01 X50 
 G01 Y70 

G03 X30 Y50 R20  

G01 X30 Y10  

G02 X20 Y20 R10  

G02 X10 Y30 R10  

G01 X50 

G03 X70 Y50 R20  

G00 Z5 

G91 G28 X0 Y0 Z0  

M05 

M30 

 
 

 

 

RESULT: 

 

Thus the manual part program was written to the given dimensions and executed in CNC milling. 
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Write a manual part program for Rectangular Pocketing operation for the 
component shown in DWG.NO.5. Profile depth=3mm 

 

DWG.NO.5 

 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 100x100x10 MATERIAL: Aluminium 

PROGRAM NO:1005 DWG.NO:5 

 

Sl.No 

 

Operation 

 

Tool type 

 

Tool dia., mm 
Tool 

Station 
No. 

Tool 

length 
offset No. 

Spindle 

speed, rpm 

Feed, 

mm/min 

 

1 
Slotting & 
Pocketing 

 

Slot cutter 
 

5 
 

1 
 

1 
 

1500 
 

35-45 

RECTANGULAR POCKETING 

G172 I(*i1) J(*j1) K(*k1) P(*p1) Q(*q1) R(*r1) X(*x1) Y(*y1) Z(*z1) 
G173 I(*i2) K(*k2) P(*p2) T(*t2) S(*s2) R(*r2) F(*f2) B(*b2) J(*j2) Z(*z2) 

 

INPUT DATA FOR G172 

I – Length of the pocket in X direction 

 J – Length of the pocket in Y direction  

K – Corner radius ( always zero) 
P – when P = 0 , roughing & when p = 1 , Finishing .  

Q -- Depth of cut for each pass .i.e. Pocket Z increment. 

 R-- Absolute Z from surface X -- Pocket corner X 

Y – Pocket corner Y 
Z – Absolute Z base of pocket 

 

INPUT DATA FOR G173 

I – Pocket side finish allowance  

K--Pocket base finish allowance  

P—Cut width Percentage  
T—Pocket Tool 

S—Spindle speed for roughing 
R—Roughing feed for z  
F--Roughing feed XY 

B—Finishing spindle speed  

J—Finishing feed &  

Z—Safety Z 
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RECTANGULAR POCKETING 

EX.NO: 10 

DATE: 

AIM: 

To write a manual part program for Rectangular Pocketing operation for the 

component shown in the DWG. NO.5 

 

 

MATERIAL REQUIRED: 

 

  

Material: Aluminum 

Size: Length 100mm, Width 100mm, Thickness 10mm 

 

PROGRAM: 

 

O0005 

G21 G94 

G91 G28 X0 Y0 Z0  

M06 T01 

M03 S1200 

G90 G00 X0 Y0 Z5 

G172 P0 Q1 R0.5 X-25 Y-25 Z-3 I50 J50 K0 

G173 P80 T1 S1200 R30 I0.1 K0.1 F70 B2000 J40 Z5  

G172 P1 Q1 R0.5 X-25 Y-25 Z-3 I50 J50 K0 

G173 P80 T1 S1200 R30 I0.1 K0.1 F70 B2000 J40 Z5 G00 Z5 

G91 G28 X0 Y0 Z0  

M05 

M30 

 

 

 

 

 

 

 

RESULT: 

 

Thus the manual part program was written to the given dimensions and executed in 

CNC milling 
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CNC TURNING CODES 
 
 

 

AIM: To study various CNC Turning codes and addresses 
 

 

G Codes 
 

G00: Point to point positioning (Rapid traverse) 
 

G01: Linear interpolation 
 

G02: Circular interpolation clockwise 
 

G03: Circular interpolation counter clockwise 
 

G04: Dwell, Exact stop 
 

G17: X Y Plane selection 
 

G18: Z X plane selection 
 

G19: Y Z Plane selection 
 

G20: Input in inch 
 

G21: Input in metric (mm) 
 

G28: Return to reference point 
 

G32: Thread Cutting 
 

G40: Cutter compensation cancel 
 

G41: Cutter Compensation left 
 

G42: Cutter Compensation right 
 

G49: Tool length compensation cancel 
 

G50: Work co-ordinate Change / Max Spindle speed setting 
 

G70: Finishing cycle 
 

G71: Stock removal in turning 
 

G72: Stock removal in facing 
 

G73: Pattern repeating 
 

G74: Peck drilling in z axis 
 

G75: Grooving in x axis 
 

G76: Thread Cutting Cycle 

 

G80: Canned cycle cancel 
 

G90: Cutting cycle A 
 

G92: Thread cutting cycle 
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G94: Cutting cycle B 
 

G96: Constant surface speed control 
 

G97: Constant surface speed control cancel 
 

G98: Feed per minute 
 

G99: Feed per revolution 

 

M Codes 
 

M00: Program stop 
 

M01: Optional (planned) stop 
 

M02: End of program 
 

M03: Spindle forward clockwise 
 

M04: Spindle forward counter clockwise 
 

M05: Spindle stop 
 

M06: Tool change 
 

M08: Coolant ON 
 

M09: Coolant OFF 
 

M10: Chuck open 
 

M11: Chuck close 
 

M62: Output 1 ON 
 

M63: Output 2 ON 
 

M64: Output 1 OFF 
 

M65: Output 2 OFF 
 

M66: Wait input 1 ON 
 

M67: Wait input 2 ON 
 

M76: Wait input 1 OFF 
 

M77: Wait input 2 OFF 
 

M98: Sub program Call 
 

M99: Sub program Exit 
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85



CATIA cadcamguru 

 

 

Write a manual part program for simple Turning and Facing operation for component 
shown in DWG.NO.T01  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

DWG.NO.T01  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium  

PROGRAM NO:1001  DWG.NO:1   

    Tool 

Tool 

Spindle 

Feed, 
Sl.No Operation Tool type Tool dia., mm Station speed, offset No. mm/min 

    No.  rpm  

1 

Simple 

SDJCR121H11 DCMT11T304 1 1 1200 45 
Facing        
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PLAIN TURNING AND FACING 
 

EX.NO: 11 

 

DATE: 

 

AIM:  
To write a manual part program for simple turning and facing operation for 

component shown in DWG.NO.T01 

 

MATERIAL REQUIRED: 

 

Material : Aluminium 

Size : Length 70mm, Diameter 22mm 

PROGRAM:  

O0001 G00 Z3 

G21 G98 G00 X21.5 

G28 U0 W0 G01 Z-30 F45 

M06 T0101 G00 X23 

M03 S1200 G00 Z3 

G00 X23 Z3 G00 X21 

G00 Z-0.5 G01 Z-30 F45 

G01 X-1 F45 G00 X23 

G00 Z3 G00 Z3 

G00 X23 G00 X20.5 

G00 Z-1 G01 Z-30 F45 

G01 X-1 F45 G00 X23 

G00 Z3 G00 Z3 

G00 X23 G00 X20 

G00 Z-1.5 G01 Z-30 F45 

G01 X-1 F45 G00 X23 

G00 Z3 G28 U0 W0 

G00 X23 M05 

G00 Z-2 M30 

G01 X-1 F45  
 
 
 
 

 

RESULT: 

 
Thus the manual part program was written to the given dimensions and 

executed in CNC Lathe. 
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Write a manual part program for Step Turning operation with G90 cycle for 
component shown in DWG.NO.T02  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

DWG.NO.T02  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium  

PROGRAM NO:1002  DWG.NO:2   

    Tool 

Tool 

Spindle 

Feed, 
Sl.No Operation Tool type Tool dia., mm Station speed, offset No. mm/min 

    No.  rpm  

1 

Step 

SDJCR121H11 DCMT11T304 1 1 1200 30 
Turning        

 

Cutting Cycle 
G90 X(U) Z(W) F(*f)  
X Diameter to which the movement is being made.  
U The incremental distance from the current tool position to the required final 
Diameter Z The Z Axis Co-ordinate to which the movement is being made. 
W    The incremental distance from the current tool position to the required Z axis Position 
fFeed rate 
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STEP TURNING 
 

EX.NO: 12 

 

DATE: 

 

AIM:  
To write a manual part program for step turning operation with G90 cycle for 

component shown in DWG.NO.T02 

 

MATERIAL REQUIRED: 

 

Material 

Size 

 

: Aluminium  
: Length 70mm, Diameter 22mm 

 

PROGRAM: 

 

O0001 

G21 G98 

G28 U0 W0 

M06 T0101 

M03 S1200 

G00 X22 Z1 

G90 X22 Z-30 F30 

X21 

X20 

X19 

X18 

X17 

X16 

X15 

X14 

G00 X14 Z1 

G90 X14 Z-15 F30 

X13 

X12 

X11 

X10 

G28 U0 W0 

M05 

M30 
 

 

RESULT: 

 
Thus the manual part program was written to the given dimensions and 

executed in CNC Lathe. 
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Write a manual part program for Taper Turning operation for component shown 
in DWG.NO.T03  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

DWG.NO.T03  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium  

PROGRAM NO:1003  DWG.NO:3   

    Tool 

Tool 

Spindle 

Feed, 
Sl.No Operation Tool type Tool dia., mm Station speed, offset No. mm/min 

    No.  rpm  

1 

Taper 

SDJCR121H11 DCMT11T302 3 3 1000 30 
Turning        

 
Cutting Cycle 
G90 X(U) Z(W) R F 

X Diameter to which the movement is being made.  
U The incremental distance from the current tool position to the required final 
Diameter Z The Z Axis Co-ordinate to which the movement is being made.  
W The incremental distance from the current tool position to the required Z axis Position R The 
difference in incremental of the cut start radius value and the cut finish radius value. 
fFeed rate 
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TAPER TURNING 
 

EX.NO:13 

 

DATE: 

 

AIM:  
To write a manual part program for taper turning operation for component shown 

in DWG.NO.T03 

 

MATERIAL REQUIRED: 

 

Material 

Size 

 

: Aluminium  
: Length 70mm, Diameter 22mm 

 

PROGRAM: 

 

O0002 

G21 G98 

G28 U0 W0 

M06 T0101 

M03 S1200 

G00 X22 Z1 

G90 X22 Z-30 R0 F30 

X22 R-0.5 

X22 R-1 

X22 R-1.5 

X22 R-2 

X22 R-2.5 

X22 R-3 

X22 R-3.5 

X22 R-4 

X22 R-4.5 

X22 R-5 

X22 R-5.5 

G28 U0 W0 

M05 

M30 
 
 
 
 
 

 

RESULT: 

 
Thus the manual part program was written to the given dimensions and 

executed in CNC lathe. 
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Write a manual part program for Multiple Threading operations for component 
shown in DWG.NO.T06  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

DWG.NO.T06  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium   

PROGRAM NO:1006  DWG.NO:6   

    Tool 
Tool offset 

 Spindle 
Feed, 

Sl.No Operation Tool type Tool dia., mm Station 
 

speed, 
No. 

 
mm/min     

No. 
 

rpm        

 Multiple        

1 Rough SDJCR121H11 DCMT11T304 1 1  1200 35 

 turning        

2 Finishing SDJCR121H11 DCMT11T302 2 2  1450 25 

3 Grooving HSS 3mm width 5 5  750 15 
 

MULTIPLE THREADING CYCLE 

G76 P(m) (r)(a) Q(*q1) R(*r1)   
            G76 X(*x) Z(*z) P(*p2) Q(*q2) F(*f) 

Where 

m- Repetitive count in finishing (1 to 99) r = Pull out angle 

a= Angle of tool tip 

*X = Minor diameter (core diameter) 

*z = End position of thread 

*p2 = Height of thread as a radius value x 1000, value in microns e.g. 1.02mm becomes p1020 

*q2 = depth of the first cut as a radius value x 1000 , value is microns. E.g. 0.25 mm becomes Q250 

*f = Lead or pitch of thread. E.g. lead 1.5 = F1.5 

*q1 = Min. cutting depth 

*r1 = Finishing allowance 
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THREADING 

 

EX.NO:14 

 

DATE: 

 

AIM:  
To write a manual part program for multiple threading operation for component 

shown in DWG.NO.T06 

 

MATERIAL REQUIRED: 

 

      Material : Aluminium 

Size: : Length 70mm, Diameter 22mm 

 

 

 

PROGRAM: 

 
O0006 

G21 G98 

G28 U0 W0 

M06 T0404 

M03 S600 

G00 X22.5 Z2 

G76 P031560 Q050 R0.02 

G76 X20.162 Z-20 P920 Q100 F1.5 

G28 U0 W0 

M05 

M30 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

RESULT 

 
Thus the manual part program was written to the given dimensions and 

executed in CNC lathe. 
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Write a manual part program for External Grooving operation for component 
shown in DWG.NO.T05  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

DWG.NO.T05  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium  

PROGRAM NO:1005  DWG.NO:5   

     Tool 

Tool 

Spindle 

Feed, 
Sl.No Operation Tool type Tool dia., mm Station speed, offset No. mm/min 

     No.  rpm  

 Multiple       

1 Rough SDJCR121H11 DCMT11T304 1 1 1200 35 

 turning       

2 Finishing SDJCR121H11 DCMT11T302 2 2 1450 25 

3 Grooving HSS 3mm width 5 5 750 15 

GROOVING CYCLE      

 G75 R (*r1)      

 G75 X(u) Z(w) P(*p) Q(*q) F (*f)     

Where,  r1-Return Amount  w-Total Depth along Z Axis ( Incremental) 
 X-Total Depth along X Axis ( Absolute) p-Peck Increment in X Axis in microns 

 u-Total Depth along X Axis ( Incremental) q -Stepping distance in Z Axis in microns 

 z-Total Depth along Z Axis ( Absolute) f -Feed Rate in mm   
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GROOVING 

 

EX.NO:15 

 

DATE: 

 

AIM:  
To write a manual part program for external grooving operation for component 

shown in DWG.NO.T05 

 

MATERIAL REQUIRED: 
Material : Aluminium  
Size : Length 70mm, Diameter 22mm 

 

PROGRAM: 
O0005 

G21 G98 

G28 U0 W0 

M06 T03  
M03 S1200 

G00 X22 Z2 

G71 U0.5 R1 

G71 P10 Q20 U0.1 W0.1 F45 

N10 G01 X8 Z0  
G01 X10 Z-3 

G01 Z-16 

G01 X13 

G01 X15 Z-19 

G01 Z-24  
G03 X20 Z-29 R5 

G01 Z-36 

N20 G01 X22 Z-39 

M03 S1600 

G70 P10 Q20 F30  
G28 U0 W0 

M06 T0707 

M03 S600 

G00 X10.5 Z-8 

G75 R1  
G75 X7 Z-10 P100 Q1000 F40 

G28 U0 W0 

M05 

M30 

 

RESULT  
Thus the manual part program was written to the given dimensions and 

executed in CNC lathe. 
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Write a manual part program for Multiple Turning operation for component 
shown in DWG.NO.T04  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

DWG.NO.T04  
 

PLANNING AND OPERATIONS SHEET 

BILLET SIZE: 22x60  MATERIAL: Aluminium  

PROGRAM NO:1004  DWG.NO:4   

    Tool 

Tool 

Spindle 

Feed, 
Sl.No Operation Tool type Tool dia., mm Station speed, offset No. mm/min 

    No.  rpm  

 Multiple       

1 Rough SDJCR121H11 DCMT11T304 1 1 1200 35 

 turning       

2 Finishing SDJCR121H11 DCMT11T302 2 2 1450 25 

MULTIPLE THREADING CYCLE 
G76 P(m) (r)(a) Q(*q1) R(*r1) 

G76 X(*x) Z(*z) P(*p2) Q(*q2) F(*f) 

Where 
m- Repetitive count in 

finishing (1 to 99) r = 

Pull out angle 

a= Angle of tool tip 

*X = Minor diameter (core diameter) 

*z = End position of thread 

*p2 = Height of thread as a radius value x 1000, value in microns e.g. 1.02mm becomes p1020 

*q2 = depth of the first cut as a radius value x 1000 , value is microns. E.g. 0.25 mm becomes Q250 
*f = Lead or pitch of thread. E.g. lead 1.5 = F1.5 
*q1 = Min. cutting depth 

*r1 = Finishing allowance 
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CANNED CYCLE – MULTIPLE TURNING 

 

EX.NO: 16 

 

DATE: 

 

AIM:  
To write a manual part program for multiple turning operation for component shown in 

DWG.NO.T04 

 

MATERIAL REQUIRED: 

Material : Aluminium  
Size : Length 70mm, Diameter 22mm 

 

PROGRAM: 

 
O000 

G21 G98 

G28 U0 W0 

M06 T0303 

M03 S1200 

G00 X22 Z2 

G71 U0.5 R1 

G71 P10 Q20 U0.1 W0.1 F45 

N10 G00 X7 Z0 

G01 X9 Z-2 

G01 Z-10 

G02 X14 Z-15 R5 

G01 Z-23 

G03 X19 Z-28 R5 

G01 Z-36 

N20 G01 X22 Z-39 

M03 S1600 F30 

G70 P10 Q20 

G28 U0 W0 

M05 

M30 
 
 
 
 
 
 
 
 

RESULT  
Thus the manual part program was written to the given dimensions and executed in CNC 

lathe. 
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CNC MACHINE FAILURES AND TROUBLESHOOTING 

 
Besides portraying decent durability, CNC machines are known for being long-lasting and can be 

relied upon due to their redundancy. However, even the most reliable CNC machines can frequently 

encounter malfunctions, be it minimal or substantial. 

These deterrents, if minimal, can be addressed by a technician right away. But if the malfunction turns 

out to be substantial, it can lead to prolonged downtime and tax your business financially. 

Here are the eight most common CNC machine failures and their solutions that you must be aware of 

if your company employs a benchtop CNC mill to perform mundane tasks. 

 

1. Using Inappropriate Cutting Tools or Settings 
Picking an inappropriate cutting tool can degrade the final build quality of the product, typically visible 

through rough edges, raised marks, or burn spots on the material’s corners.  

Poor material finishes directly result from either the tool being blunt or an improper feed speed ratio. 

Another leading cause can be choosing inaccurate tool dimensions for the task at hand in terms of the 

sizes, build quality or material. 
 

Solution 
Resolving this issue requires that you choose the appropriate tool and setting for the build quality and 

material. You must refer to proper instruction manuals that state the parameters for various tools and 

quality used. 

 

2. Programming Errors  
Since sophisticated equipment gets operated by CNC computers, several issues in CNC machining arise 

from incorrect programming. 

This scenario might be due to a lack of understanding of the various G and M codes employed for the 

controller, improper set-up, or feeding erroneous data variables into the CNC controller. 
 

Solution 
New operators must be trained adequately in all different approaches in which CNC machines are 

programmable. Machine suppliers can provide new operators with comprehensive user manuals 

accompanied by training, motion sequencing, and machine operation. 

 

3. Poor CNC Machine Tool Maintenance  
Modern machines come with several mechanical parts that are constantly in motion. Therefore, CNC 

machine tools must be cleaned and maintained regularly to ensure optimal operation. 

Failing to brush off the dirt, clean the material and other debris can lead to a build-up. This scenario 

could potentially lead to inaccuracies in machining or even machine failures. 
 

Solution 
It is pivotal for machine operators to adhere to a comprehensive maintenance regime for the machine 

tools. You must frequently check the coolant or airflow levels, for instance, air filters, to establish that 

the machine continues to operate smoothly. 

 

4. Incompetent Workers and Lack of Training 
With the growing implementation of computing and programming, CNC machine tool operators require 

a distinct set of knowledge and expertise. 

99

https://www.cncmasters.com/cnc-jr-milling-machine/
https://www.southernfabsales.com/blog/types-of-milling-machines


CATIA cadcamguru 
 

 

Without relevant organizational, planning, and programming skills, workers cannot enhance the yield 

of these machines despite possessing machining skills and expertise using older machine models. 
 

Solution 
As a resolution, you must hire trained machine operators to visualize and design the machining process, 

choose the appropriate tools and sequences for the task, and write programs. 

 

5. Issues With the Power Supply  
The CNC machine tool’s display or other parts sometimes might not operate due to problems with the 

primary power supply. This scenario could lead to the machine yielding inaccurate results or failing to 

operate at all. 
 

Solution 
Ensure that you are using the correct power and voltage for the input parameters. Subsequently, check 

if the output or secondary side is functional.  

If voltage reading is low, disconnect the output wires with the power turned off, power up, and reassess 

the output side. Also, check if the LEDs on the machines are functional. 

 

6. Problems with Automatic Tool Changer  
Sometimes you might encounter issues with the automatic tool changer in your CNC Machine Tool. 

You can resolve this by learning each step of the tool-changing process.  
 

Solution 
Assess that the base, tool holder, gripper arm, support arm, and tool magazines are functioning 

smoothly. Check the swiveling and mechanical arm action to ensure that they are not causing the issue.  

 

7. Machine Vibration or Chatter 
If your CNC machine is vibrating when under operation, it could substantially shorten the life of your 

tool, negatively impact your CNC machine's durability, or sabotage the quality of your machined 

component.  
 
Solution 
You must diagnose if the noise is workpiece chatter or tool chatter. Consider adjusting the RPM of your 

machining process to ensure that the frequencies of the machining process do not resonate with the 

frequency of the material. 

 

8. Machine Tool Overheating 
Overheating can occur when dealing with high volume and prolonged durations of machining. The 

CNC machine tool might reach temperatures of over 150 degrees. This scenario could negatively affect 

your machining process's result, the tool used, and even the CNC machine. 
 

Solution  
You must be sure to clear all channels regularly and have the machine rid of dirt, soil, and debris. Plus, 

it's necessary to routinely clean up all metal shavings and the liquids utilized in cutting. 

Consider using a spindle with Air-Oil Lubrication or an Oil-Jet Lubrication spindle as it has no issues 

operating for long hours at maximum rpm. Be sure to ventilate your CNC machine to provide some 

coolant from nature as well. 
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OPERATING PROCEDURE OF MASTER CAM 

 

Step 1 
The usual modification is that is done after initializing the master cam is the alteration of the 

available screen ie modification of grid size and as per the requirement of user screen, configure, 

selection grid. Select grid size (configure 

grid) The dimensioning requirement is usually selected ie Metric or English etc. 

 

Step 2 
Once the screen and the dimensioning adjustments are done the basic required part geometry of 

the object is created by using the create command. 

Create command: Rectangle or Circle or Line or Fillet. 

 

Step 3 
After defining the tool parameters and the machining operations parameter, the job setup is done. 

The job is usually defined in terms of length width and thickness (X, Y, Z ). The selection of 

material for the job is done in jobsetup 

 

Step 4 
After the required part geometry is created, the tool path are defined on the selected geometry 

depending upon the milling operation. 

 
Tool path contour save chain done  

Tool path pocket save area or chain or polygon done 

 

Once the tool path are defined, press done, tool parameter screen will appear where in the 

required tool diameter is entered or the tool can be selected from the tool manager. 

Similarly the above step is carried out for all operations the contour parameter such as clearance, 

retract, feed, top of stock, depth are given. 

 

Step 5 
Completion of the above setup leads to operation manager where in all the operation are selected 

by select all, paths are regenerated by Regenerate path, and by Verify, machining operation is 

done. Before machining, configuration is verified where in use of job setup values are 

highlighted. 

 

Step 6 
Press post button to the get the NC program 
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GENERATION OF CNC PROGRAMME AND MACHINING USING MASTERCAM 

SOFTWARE 

AIM 

 To machine the model as per the sketch. 

Procedure: 
 

Step 1 

The usual modification is that is done after initializing the master cam is the alteration of the 

available screen ie modification of grid size and as per the requirement of user screen, 

Choose-main menu      Screen       Configure        Current Configuration File 

Select- Mill9.Mcfg(metric) 

Choose-main menu      Screen       Next menu        Sel.Grid 

Select-Active Grid, Visible Grid, Spacing x =1 and y =1, Grid Size= 110, Origin 

x=0,y=0 and choose suitable for Grid. 

 

SCREEN 

CONFIGURE 

SYSTEM CONFIGURATION 

CURRENT CONFIGURATION 

FILE 

MILL 7 MC FOR (METRIC) 

SCREEN 

SELECTION GRID 

 
 

ACTIVE GRID 

VISIBLE GRID 

DONE 

SAVE AS 

FILE NAME 

SAVE 

OIL 

BACK UP 

  

  

 

Step 2 
 

1. To create inner and outer circles. 

 Choose-main menu      Create      Arc      circpt+dia. 

 Typediameter100     Enter 

 Select origin 

 Press Esc. And reselect circpt+dia 

 Enter diameter58 

 Select origin 

 Press Esc. And reselect circpt+dia 

 Repeat same procedure for diameter 20 and22mm 
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 xi. Press Esc. to exit circle function 

 Choose it screen menu. 

 

2. To create construction of rectangle /Square 

 Choose-main menu     Create   Rectangle    1 point 

 Enter width 92 and height 92 ( bcz. given figure is square) press OK 

 Select origin 

 Press Esc to exit linefunction 

 

3. Trimming unwanted portion oflines 

 Choose-mainmenu      Modify      Trim     3 entities 

 Select 1 entity as vertical line of square inside thecircle 

2 entity as Horizontal line of square inside the circle 3 

entity as arc of the circle inside thesquare. 

4. Copy and rotate the arc 

 Choose-main menu     X form   Rotate 

 Select anywhere on arc. 

 Choose done. 

 Select origin. 

 Select copy, enter the values. No of steps 3 and angle is900
 

 Choose OK in the dialogue box remaining slots fo rcreated. 
 

XFORM  ANALYSE  DELETE  FILE 

MIRROR  POINT  CHAIN  NEW 

ROTATE  CONTOUR  WINDOW  EDIT 

SCALE  ONLY  POLYGON  GET 

MODIFY 

FILLET 

TRIM 

BREAK 

JOIN 

MORMAL 

CEPTS 

NORBS X TO 

FILLET 

RADIS 

ANGLE<180 

TRIM Y 

CHAIN 

BACK 

TRIM 

1ENTITY 

2ENTITES 

3ENTITES 

TO POINT 

MANY 

CLOSE ARC 

DIVIDE 
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ACALEXYZ  BETWEEN PTS  AREA  MERG 

TRANSLATE  ANGLE  ONLY  E LIST 

OFFSET  DYNAMIC  ALL  SAVE 

GS COLOUR  AREA/VOLUM  GROUP  SAVE SOME 

GROUP  E NUMBER  RESUIT  BROWSE 

STRETCH  CHAIN  DUPLICATE  CONVERT 

ROLL 

BACK UP 

 SURFACE 

BACKUP 

 UNDELETE 

BACKUP 

 ER NEXT 

MENU 

5. Trimming unwanted portion of lines(Square) 

 Choose-main menu    Modify     Trim     3entities 

 Select 1 Entity vertical line of square inside the arc 

2 Entity Horizontal line of square inside the arc 

3 Entity arc inside the square. 

 
6. To create construction lines 

 Choose-main menu        Create      Line       Polar 

 Enter the first co-ordinate origin 

 Enter angle in degree450
 

 Enter the line length45 

 Press Esc to exit line function 

 

7. To create inner 10 mm diameter circles 
 

 Choose- main menu      Create     Arc    circpt +dia. 

 Type diameter10     Enter   

 Select end point of inclined line. 

 Press Esc. And reselect circpt+dia 

 
8. Copy and rotate the Circle 

 Choose-main menu       Xform     Rotate 

 Select anywhere on 10 mm diameter circle 

 Choose done. 

 Select origin. 

 Select copy, enter the values. No of steps 3 and angle is900 

 Choose OK in the dialogue box remaining 3 circles for created. 
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Now your drawing is ready for operations 

 

The following operations to be conduct Using the geometry 

 

 Facing 

 Contour 

 Pocketing 

 Drilling 

Step 3 

 
1. Make job setup for given geometry 

 Choose-main menu Toolpath Job setup 

 Enter the X =110 Y=110 and Z=55 mm respectively 

 Select Display Stack and Fit to Screen. 

 Outside the drawing doted boundary red line is displayed 

2. Another option for job setup 

 Choose-main menu Toolpath Job setup 

 Select stock origin ( 0,0) 

 select the stock corners. 

 Enter the value of Z = 55 ( + value). 

 Select the display stock checkbox. 

 Select fit stock checkbox. 

 Choose OK the stock should be enclosed by red dotted line. 
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Step 4 

1. Create tool path for Facing 

 Choose-main menu Toolpath Face 

 Select start point for the chain at periphery of the figure. 

 Choose done. 

 Right click in the tool display area and select a 10 mm flat end mill 

 from the tool library. 

 Right click on the tool display , go to tool type select face mill tool, 

 Select the facing parameters. Give Depth of cut -2mm ( -negative) 

 Select depth Cuts, Give Rough Cut 3, Finishing cut 1No. Finish Step0.5 

 Choose OK twice in the tool path should be showing figure. 
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1. Create tool path for Contour 

 Choose-main menu Toolpath Contour 

 Select start point for the chain at position1. 

 Choose done. 

 Right click in the tool display area and select a 10 mm flat end mill from the 

tool library. 

 Select the contour parameters , Give Depth of cut -53mm ( - negative), Use Multi 

passes, Depth Cuts and Lead in/out options. 

 Choose OK twice in the tool path should be showing figure. 
 

 

 
3. Create tool path for pocket 1 

 Choose-main menu Toolpath Pocket 

 Select the 58 mm diameter circle. 

 Choose done. 

 Right click in tool display area and select 8mm flat end mill from tool library. 

 Enter pocketing parameters and note that the depth should be negative say-10. 

 Choose OK the tool path should look like the picture pattern. 
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4 Create tool path for pocket 2 

 Choose-main menu Toolpath Pocket 

 Select first 22 mm diameter circle. 

 Choose done. 

 Right click in tool display area and select 5mm flat end mill from tool library. 

 Enter pocketing parameters and note that the depth should be negative-12. 

 Choose OK the tool path should look like the picture pattern. 

 

6. Create tool path for pocket 3 

 Choose-main menu Toolpath Pocket 

 Select first 20 mm diameter circle. 

 Choose done. 

 Right click in tool display area and select 3mm flat end mill from tool library. 

 Enter pocketing parameters and note that the depth should be negative say-32. 

 Choose OK the tool path should look like the picture pattern. 

 

6. Create tool path for Drilling 

 Choose-main menu Toolpath Drill 

 Select Entities Choose 10mm diameter circles one by one. 

 Choose done. Tool path is generated, Choose once again done 

 Right click in the tool display area and select a 10 mm drill mill from the tool 

library. 

 Select the drill parameters and note that the depth should be negative say-60. 

 Choose OK twice in the tool path should be showing figure. 

Step 5 

Tool path Generator 

 i.

 Choose

 - mainmenu

 Operation 

 A dialogue box appears select all regenerate path 

 When the tool path generation completes the dialogue box display 

 choose verify, a deluge box is displayed select run ( machine) item. 
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Operation management of Tool Path 
 

 

Configuration of Tool path 

If your model is square/Rectangle go to shape, select box , suppose your model is Cylindrical 

go to shape, select cylinder 
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 Program 

  

 

 

 

 

 

 

 

 

 

 Step 6 
 

Post processor NC Program 

 Choose-main menu Operation 

      A dialogue box appears select all regenerate path, choose post 

      Show path (desktop) for saving post processor Notepad file. 

  

 

 

 

Result:    The required geometry is created
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VIVA QUESTIONS 

1. Why tolerances are given to the parts?  

Because it’s impossible to make perfect settings✓  

To reduce weight of the component 

To reduce cost of the assembly 

To reduce amount of material used 

2. What is bilateral tolerance?  

Total tolerance is in 1 direction only 

Total tolerance is in both the directions✓ 

May or may not be in one direction 

Tolerance provided all over the component body 

3. Which type of tolerance provided in drilling mostly?  

Bilateral Unilateral✓

Trilateral Compound 

4. What is mean clearance?  

Maximum size of hole minus maximum size of shaft Minimum 

size of hole minus minimum size of shaft  

Mean size of hole minus mean size of shaft✓ 

Average of both size of shaft and hole 

5. Which of the following is incorrect about tolerances? 

Too loose tolerance results in less cost✓ 

Tolerance is a compromise between accuracy and ability  

Too tight tolerance may result in excessive cost 

Fit between mating components is decided by functional requirements 

6. Bilateral tolerances are used in 

Unitary production  

Mass production✓ 

Both Unitary and mass production  

None of the above 

7. The overall width of a part is dimensioned as 3.00 ± 0.02. What is the upper limit? 

3.00 

+0.02 

3.02✓ 

0.04 
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8. How may types of Assemblies are used in CATIA  

Top down  

Bottom up 

Both top down and bottom up✓  

None of the above 

9. Abbreviation of CATIA  

Computer Aided Three Dimensional Interactive Animation Computer 

Aided Three Dimensional Interactive Application✓ Computer Assisted 

Three Dimensional Interactive Application Computer Aided Three 

Dimensional Internet Application 

10. Polar coordinates are used mostly for drawing  

Circles  

Arcs 

Vertical lines Angled 

lines✓ 

11. When the interior of an object is complicated, which of the following view is used?  

Front view  

Side view  

Top view 

Sectional view✓ 

12. When the cutting plane cuts the entire object the section is known as    
 

Full section✓  

Half section 

Revolved section Removed 

section 

13. Inclined and offset cutting planes can be used if   

 
all the hidden objects are not in one line  

all the hidden objects are in one line 

the single line nor offset sectioning is useful and shape of the object is inclined  

it is used for combined objects✓ 

14. Crane hook is to drawn by  method.  

 
full section  
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half section 

removed section revolved 

section✓ 

15. The section which cuts the object at an angle is called  

 
removed section  

broken out section 

auxiliary section✓ 

assembly section 

16. The command which is used to set a new layer is called  

 
LAYOFF  

LAYVPI  

LAYDEL  

LAYER✓ 

17. Modifying a layer consist of  

 

Line weight and line type✓  

Thawing 

Freeze 

Deleting a layer 

18. Thin parts like stiffeners, webs, bolts, rivets, etc. are  if they are cut by 

the cutting plane along their axis.  

Not hatched✓  

hatched  

sectioned 

Not sectioned 

19. Which command is used to divide the object into segments having 

predefined length?  

Divide  

Chamfer  

Trim  

Measure✓ 

20. Status bar do not contain  
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Snap  

Grid  

Erase✓  

Polar 

21. Which mode allows the user to draw 90° straight lines  

 
Osnap  

Ortho✓  

Linear 

Polar tracking 

22. To obtain parallel lines, concentric circles and parallel curves;  is 

used.  

 
Array  

Fillet  

Copy  

Offset✓ 

23. The default grid spacing in both X and Y directions is:  

 

10✓ 

20 

5 

15 

24. Scale command can be accessed easily by typing  

 
SL  
S  

SC✓ 

C 

25. What is the save extension of the sketcher file in CATIA?  

CATPart✓ 

 CATIAPart  

CPart 

None of the above 

*************************************************** 
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